Delay in InPlay & Prematch Updates

Incident Report for LSports Status Page

Resolved

The incident has been fully resolved.
Settlements for the games that were affected during the incident window will now be processed manually and delivered gradually.

If you have specific settlement requests related to this time window, we recommend opening a support ticket so we can prioritize and provide a faster response.

Thank you for your patience and understanding.
Posted Sep 27, 2025 - 22:56 IDT

Monitoring

A fix has been deployed, and our teams are now actively monitoring the system to ensure stability.
We will provide a final update once the issue is fully resolved.
Posted Sep 27, 2025 - 22:25 IDT

Update

Follow-Up Update:
We are still working on stabilizing the service.
The root cause was identified as a memory leak on one of our critical RabbitMQ clusters, which resulted in repeated crash loops.

To address this, we are currently upgrading the cluster to a stronger setup while also resolving the underlying cause of the memory leak.

Estimated time to full recovery: ~1 hour.

We will continue to keep you updated until service is fully restored.
Posted Sep 27, 2025 - 21:17 IDT

Update

The fix is still in progress and requires additional time to be fully deployed.
The new ETA for complete resolution is approximately 60 minutes.
We will keep you updated and notify you once the service is fully restored.
Posted Sep 27, 2025 - 19:57 IDT

Update

We have successfully identified the root cause of the disruption, and a fix is currently being implemented.
The estimated time for full resolution is approximately 30 minutes.
We will confirm once the service is fully restored.
Posted Sep 27, 2025 - 19:10 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 27, 2025 - 17:40 IDT

Investigating

We would like to update you that we are currently experiencing a disruption impacting all Live Feed updates (both InPlay and Prematch).
Our engineering teams are fully engaged and treating this with the highest priority to restore the service as quickly as possible.

In the meantime, we kindly recommend that you suspend odds on your side until stability is restored. Please note that we are also working on a solution to automatically suspend the odds on your behalf.

We will share further updates as soon as we have progress to report.
Posted Sep 27, 2025 - 17:22 IDT
This incident affected: TRADE360 (Feed API) and OddService (Feed).