Trade360 – Odds Feed Delays (Partial Impact)

Incident Report for LSports Status Page

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 14:07 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2025 - 13:57 IDT

Investigating

We have identified an issue causing delayed updates and stuck odds for some fixtures. A fix is in progress, and we will provide the next update once progress is made.
Posted Aug 11, 2025 - 11:53 IDT
This incident affected: TRADE360 (Feed API, Snapshot API).