Service stability has been confirmed following the fix. Configuration changes (fixtures/leagues, provider lists, templates, odds settings) are processing as expected, and data delivery is operating normally with no residual backlog observed. We are returning to standard monitoring. If any anomalies are observed on your side, please contact Support.
Posted Sep 05, 2025 - 15:38 IDT
Monitoring
The fix has been applied and service should be back to normal. We are monitoring for stability.
Posted Sep 05, 2025 - 15:22 IDT
Identified
Partial data delivery is impacted due to a degradation in processing recent settings changes (e.g., fixture/league configurations, provider lists, templates, odds settings). Fixtures without recent changes are not affected. Work on the fix is ongoing.
Posted Sep 05, 2025 - 14:23 IDT
Investigating
We are investigating an issue causing partial degradation in Trade360. Some markets or events may not be delivered to customers, and certain configuration changes may fail or not take effect. Odds updates are not affected. Engineers are working to restore full functionality. Updates will follow as soon as meaningful progress is made.